Excel INDIREKT Funktion

von | 14.02.2022

Überblick

Die Excel INDIREKT Funktion wird dazu verwendet, um aus einem Text eine tatsächliche Zellenreferenz zu erstellen. Diese kann ebenfalls aus unterschiedlichen Funktionen bestehen, um damit eine äußerst dynamische Zellenreferenz zu definieren.

Excel INDIREKT Funktion

Syntax

=INDIREKT(Bezug; [A1])

 

Argumente

Bezug – Hier wird die gewünschte Referenz angegeben.
[A1] – Es kann zwischen dem R1C1-Format und dem A1-Format gewählt werden. WAHR = A1-Format

 

Anmerkungen

Die Excel INDIREKT Funktion wird verwendet, um aus einem Textformat eine lesbare Zellenreferenz zu erstellen. Hierbei spielt es keine Rolle, ob der Text über Anführungszeichen oder eine weitere Zellenreferenz definiert wird. Dies kann zunächst für Verwirrung sorgen, ist jedoch in einem einfachen Beispiel erklärt.

=INDIREKT(„A1“)

Diese Funktion gibt den Inhalt der Zelle A1 wieder. Angenommen, in Zelle B5 steht „A1“ als Text, würde folgende Funktion dasselbe Ergebnis liefern.

=INDIREKT(B5)

 Wie man sieht, kann nun über die Zelle B5 entschieden werden, welche Zelle die Funktion referenziert, oder direkt in die Formel zu gehen. Hierbei entstehen jetzt einige Möglichkeiten, diese Funktion sinnvoll zu nutzen.

 

 

Wofür INDIREKT Funktion nutzen?

Wie bereits festgestellt, kann die INDIREKT Funktion als direkte Zellenreferenz verwendet werden, um dynamische Formeln noch dynamischer zu gestalten. Weitere Einsatzmöglichkeiten können sein:

  • Eine Zelle benötigt änderbare Tabellenblatt-Namen
  • Eine Referenz soll sich nicht beim Kopieren der Formel verändern
  • Die Zellenreferenz kann über mehrere weitere Funktionen und Verbindungen erstellt werden
  •  Zellenreferenzen können über eine Hilfstabelle verwaltet werden

 

 Da die INDIREKT Funktion die Referenz zu jederzeit berechnet, kann die Funktion zu Performance-Problemen führen.

 

Beispiele zur INDIREKT Funktion

Die INDIREKT Funktion kann zur Unterscheidung unterschiedlicher Tabellenblätter verwendet werden.

=INDIREKT(„BLATT!“&“A1“)

Hier kann sowohl das Tabellenblatt als auch die Zellenreferenz individuell angepasst werden, um die Funktion dynamischer zu gestalten.

 

Mittels der INDIREKT Funktion kann ein Array mit der Hinzuziehung der ZEILE Funktion gebildet werden.

=ZEILE(INDIREKT(„1:99“))

Erstellt ein Array von 1 bis 99 ({1;2;3;4;…}) welches zu Weiterverwendungen eingesetzt werden kann, und bei Bedarf dynamisch angepasst werden sollte.

 

Ebenfalls kann die Funktion mit der SUMME Funktion kombiniert werden, um aus fixierten Referenzen Summen zu bilden.

=SUMME(INDIREKT(„A1:A10“)

Bildet die Summe aus den Zellen A1 bis A10, welche dynamisch angepasst werden können.

 

Weitere Ressourcen

Weitere Hilfe findest du ebenfalls auf der offiziellen Microsoft Seite oder in unserem Video, indem wir dir die INDIREKT-Funktion noch einmal genau erklären.