Excel SVERWEIS Funktion

von | 10.09.2022

Überblick

Die Excel SVERWEIS Funktion wird dazu verwendet, um aus einer Matrix, durch ein definiertes Suchkriterium ein bestimmter Wert aus einer beliebigen Spalte zu extrahieren. Dies ist besonders nützlich, wenn aus einer großen Datenmenge nur ein spezifischer Datensatz benötigt wird.

Excel SVERWEIS Funktion

Syntax

=SVERWEIS(Suchkriterium; Matrix; Spaltenindex; [Bereich_Verweis])

 

Argumente

Suchkriterium – Nach diesem Wert wird in der definierten Matrix gesucht.
Matrix – In diesem Wertebereich wird nach dem Suchkriterium gesucht.
Spaltenindex – Definiert die Spalte, in welcher in der Matrix nach dem Suchkriterium gesucht wird. Werte beginnen bei 1.
[Bereich_Verweis] – Definiert mit WAHR oder FALSCH, ob das Suchkriterium exakt sein soll, oder sich nur annähern muss.

 

Anmerkungen

Die Excel SVERWEIS Funktion ist wohl, neben der WENN Funktion, die am häufigsten verwendete Funktion. Der Grund dafür kommt auch nicht von irgendwo. Der SVERWEIS dient als Grundlage für eine Vielzahl an Logiken, Suchen und weiteren Anwendungen in Microsoft Excel. Zur optimalen Nutzung gehören jedoch eine Reihe an wichtigen Anmerkungen.

 

Excel SVERWEIS Grundlagen

Der SVERWEIS sucht zuerst in der ersten Spalte der gewählten Matrix nach dem Suchkriterium. Sobald ein Wert anschlägt, gibt er in der gefundenen Zeile in die definierte Spalte. Also bei z.B. einem Spaltenindex von 3 in die dritte Spalte. Den dort gefunden Wert bekommt man nun im SVERWEIS zurück.

Um den SVERWEIS also korrekt durchführen zu können, ist es nötig, dass die Suchspalte, mit den eindeutigen Werten in der ersten Spalte steht. Andernfalls ist es nicht möglich die Logik korrekt durchzuführen, und sollte her zum XVERWEIS greifen. Ebenso ist es wichtig zu wissen, dass die Funktion IMMER den ersten gefundenen Wert zurückgibt. Sind also gesuchte Werte mehrmals in der Suchmatrix vorhanden, kann der zweite Wert mit dem SVERWEIS nicht gefunden werden.

 

Mit dem Excel SVERWEIS Tabellen vergleichen

Der SVERWEIS kann ebenfalls dazu genutzt werden, zwei Tabellen auf Duplikate zu vergleichen. Dazu müssen lediglich die Inhalte der ersten Tabelle als Suchkriterium in der zweiten Tabelle herhalten und vice versa. Zu dieser Problemstellung haben wir ein genaues Video erstellt, in dem wir dir die Lösung einfach erklären.

 

 

SVERWEIS mit 2 Suchkriterien

Durchaus ist es möglich, mit den SVERWEIS und mehrere Suchkriterien zu kombinieren. Hier ist eine weitere Funktion, nämlich die WAHL() notwendig.

=SVERWEIS(Suchkriterium1&Suchkriterium2;WAHL({1.2};A:A&B:B;C:C);2;0)

Diese Formel lässt es einfach zu, aus zwei unterschiedlichen Spalten Werte für deinen SVERWEIS zu ziehen. Dein Suchkriterium 1 & 2 suchen jeweils in Spalte A:A und Spalte B:B nach Werten in Spalte C:C.

 

SVERWEIS in Spalte kopieren

In manchen Fällen möchte man die SVERWEIS Funktion eine ganze Spalte nach unten kopieren. Oder das Ziel ist es, den SVERWEIS in eine andere Zelle zu kopieren, und die Matrix soll dieselbe bleiben. Für beide Probleme gibt es dieselbe Abhilfe, nämlich den absoluten Bezug in Excel.

=SVERWEIS(Suchkriterium;$A$1:$E$4;2)

Indem vor der Spalte und der Zeile, sowohl am Anfang, als auch am Ende der Matrix ein Dollar-Symbol gesetzt wird, sagt man Excel einfach, dass sich diese Bezüge nicht verändern sollen. Das kann manuell hinzugefügt werden, oder mit der F4 Taste direkt nach der Auswahl der Matrix aktiviert werden. Das $ fixiert jeweils das nächste Symbol. Möchte man also nur die Spalte fixieren, aber beim Kopieren in der Spalte die Zeile dynamisch halten, darf kein Dollar-Symbol vor der Zeile gesetzt sein.

 

SVERWEIS mit mehreren Suchkriterien

Sind mehr als 2 Bedingungen notwendig, kann die zuvor definierte Formel leicht auf beliebig viel Kriterien verlängert werden. Ein SVERWEIS mit 3 Bindungen würde dann zum Beispiel so aussehen.

=SVERWEIS(Suchkriterium1&Suchkriterium2&Suchkriterium3;WAHL({1.2.3};A:A&B:B&C:C;D:D);3;0)

Aufbauen darauf, können mehrere Suchkriterien im SVERWEIS verwendet werden.

 

Weitere Ressourcen

Weitere Hilfe findest du ebenfalls auf der offiziellen Microsoft Seite.